ifn't

JPDev@programming.dev to Programmer Humor@programming.dev – 750 points –
124

You are viewing a single comment

Some C++ style guides suggest the following naming convention for functions that crash on any error

OpenFileOrDie()

PHP has the always wonderful (and perfectly functional) syntax of

logUserIn() or die();

Or Perl

Perl also has unless() for the very purpose in OP, which is a more sensible choice.

Oh, and if you need to reinforce your belief that Perl is a mess, the single-quote character can be used as a package separator instead of "::". This was set in the 90s when nobody was quite sure of the right syntax for package separators, so it borrowed "::" from C++ and the single quote from Ada (I think).

That means the ifn't() in OP can be interpreted as calling the t() function on the ifn package.

The "::" separator is vastly preferred, though. Single quotes run havoc on syntax highlighting text editors (since they can also be used for strings). About the only time I've seen it used is a joke module, Acme::don't.

Personally, I like to call catched exception variables up, so for a rethrow I can throw up;.

Except rethrowing an exception in C# is just throw;, anything else is a crime against the person who reads your stacktraces.

I mean, it makes sense to call ComplainToErrorAndExit just 'die', no?

One of the modules in a project I'm working on is called VulkanOrDie which always makes me crack up when I see it in the compilation messages.

It's funnier when you try to SysCallAndDie() :-P

(that's a real thing in perl btw - I guess that function didn't get the memo)

Now what about GZDoom's GoAwayAndDie();?